
SeaLeft FAQ Manual 
Introduction 
SeaLeft FAQ is an application that can be used for self-quizzing. It presents questions in a multiple choice 

format and can be used for any subject to which such questions can be written.  SeaLeft FAQ provides 

the following features: 
 

• Quizzes with any number of multiple choice questions. 

• The ability to be re-asked “problem” questions until they are answered correctly. 

• Performance history so you can see how you improve over time. 

• The ability to create your own quizzes. 

 

This manual provides everything you need to be able to use SeaLeft FAQ to take quizzes and to create 

your own quizzes.  It is divided into the following sections: 

• At a Glance – Briefly describes the main window of SeaLeft FAQ. 

• Quick Start – Briefly describes how to take a quiz in SeaLeft FAQ. 

• SeaLeft FAQ in Depth – Describes in detail all parts of the SeaLeft FAQ application. 

• Creating Quizzes – Describes in detail how to create your own quizzes for use in SeaLeft FAQ. 

 

At a Glance 
SeaLeft FAQ’s main window is divided into several sections. 

 

 



1. Menu Bar 

Access the menus to start a quiz or review past performance. 

2. Question Area 

View the current quiz question as well as the history of all questions already asked in the current 

quiz. 

3. Answer Area 

Click the desired answer to the current quiz question. 

4. Quiz Status 

Displays the status of the current quiz, including how many questions have been asked, how 

many remain, how many have been answered correctly, and the current percentage score. 

 

Quick Start 
You can take a quiz with SeaLeft FAQ in one of three ways: 

• Double-click a FAQ file in Windows.  This should automatically start SeaLeft FAQ, which will 

begin running the double-clicked quiz file immediately. 

• Select Open Quiz from the File menu.  This will present an Open Quiz dialog that you can use to 

locate and open a FAQ file in Windows. 

• Select a previously run quiz from the history section of the File menu.  This will start that 

previously run quiz and is useful if you are attempting the same quiz frequently. 

Once you have started a quiz the first question of that quiz will be displayed in the Question Area. The 

Answer Area will then display two to six possible answers for the question.  When you click an answer 

the Question Area will show whether you have answered correctly or not and will then present the next 

question. 

You will continue to be asked questions until the quiz is complete.  The Quiz Status will show how far 

through the current quiz you have progressed.  Once you answer the last question then the Question 

Area will show your final performance on the quiz. 

After you have attempted a quiz at least once, you can review your past 

performance on that quiz in the Performance History window.  This can 

be accessed by selecting Performance from the File menu of the main 

SeaLeft FAQ window. 

 

 

 

  



SeaLeft FAQ in Depth 

Main Window 
Menu Bar 

 
 

The Menu Bar provides access to options used to start quizzes and to review past performance on 

quizzes. 

File Menu 

Click the File menu to access the following options: 

• Open Quiz – Clicking this option will display an Open Quiz dialog window from which you can 

choose a quiz to take. 

• Performance – Clicking this option will display the Performance History window.  From here you 

can review your past performance on any quizzes you have completed. 

• Ask Question Until Correct – This option may be turned on and off by clicking on it.  When this 

option is turned on a checkmark will appear next to it in the menu.  In this case, SeaLeft FAQ will 

“shuffle” incorrectly answered questions back into the remaining questions of a quiz.  

Incorrectly answered questions will continue to be asked until they are answered correctly.  This 

helps to provide more exposure to “problem” questions.  When this option is turned on, the 

number of remaining questions in the quiz will increase by one for each question that is 

answered incorrectly.  Turning this option off will cause questions to only be asked once per quiz 

whether they are answered correctly or not.  The setting of this option is remembered between 

sessions in SeaLeft FAQ. 

• Check File Extensions – Clicking this option will cause the application to check if the .faq quiz file 

type is associated with SeaLeft FAQ.  If it is then you will be able to double-click such files in 

Windows and have their quizzes start automatically.  If it is not, then SeaLeft FAQ will ask if you 

want to associate the file extension with it. 

• File History – SeaLeft FAQ will remember up to the last four most recent quizzes you have taken. 

These will be displayed in the File menu and can be clicked to immediately start the quiz without 

having to use the Open Quiz option. 

• Exit – Selecting this option will close the SeaLeft FAQ application. 

Click the Help menu to access the following options: 

• Manual – Clicking this option will open this manual document. 



• About – Clicking this option will show the version and copyright information for SeaLeft FAQ. 

 

Question Area 

 
When you are taking a quiz questions will appear in the question area.  When you answer a question the 

question area will show if you have answered the question correctly or not.  Each time you take the 

same quiz, questions will be mixed into a different order.  This helps to ensure you pay attention to the 

question and not where it appears in the quiz. 

If you answer a question incorrectly, the correct answer will be displayed in red.  Each question remains 

in the question area through the end of the test.  After the test has finished you can scroll back through 

the test and easily find the questions you answered incorrectly. 

Once you finish a test the question area will display your final results.  It will display the number of 

questions you answered correctly out of the total and will also express your performance as a 

percentage. 

 

Answer Area 

 
When you start a quiz the Answer Area will change to provide you with the possible answers to each 

question.  Each question asked may have from two to six multiple choice answers, with each choice 

presented on its own button.  To answer the current quiz question click the button of the option you 

wish to choose. 

Each time you take the same quiz, answers for each question will be mixed into a different order.  This 

helps to ensure you pay attention to the answers and not where they're located. 

 



Quiz Status 

 
The Quiz Status appears at the bottom of the main window.  It displays the following information while 

you are taking a quiz: 

• Question – This section shows which question out of the total number of questions in the quiz 

you are currently on. 

• Correct – This section shows the number of questions you have answered correctly in the quiz 

as you proceed. 

• Incorrect – This section shows the number of questions you have answered incorrectly in the 

quiz as you proceed. 

• Score – This section shows the percent of questions you have answered correctly in the quiz as 

you proceed. 

 

Performance History 
The Performance History window can be used to review your performance on quiz attempts you’ve 

taken in the past.  You can access the Performance History window by clicking the Performance option in 

the File menu of SeaLeft FAQ’s main window. 

The Performance History window is divided into several sections. 

 



1. Quiz List 

Lists all the different quizzes you have attempted. 

2. Performance Graph 

Shows a line graph plotting your performance for each attempt of the quiz currently selected in 

the Quiz List. 

3. Overall Summary 

Shows details about your overall performance across all attempts of the quiz currently selected 

in the Quiz List. 

4. Selected Attempt 

Shows your performance details for the specific quiz attempt currently selected in the 

Performance Graph. 

 

Quiz List 

 
The Quiz List displays an alphabetical list of the names of all the quizzes you have completed at least 

once.  When you select a quiz from this list the Performance Graph, Overall Summary, and Selected 

Attempt sections change to display the performance you have had for that quiz. 

A “Reset Performance” button appears immediately below the Quiz List.  When you click this button, 

SeaLeft FAQ will delete all the history you have accumulated for the quiz selected in the Quiz List.  A 

confirmation window will be displayed before this is done to ensure that you really want to reset your 

performance.  Once you choose to do this, your past performance will be deleted and cannot be 

recovered. 

 

Performance Graph 

 
The Performance Graph displays a line graph showing how you have done on the quiz selected in the 

Quiz List.  The graph shows the percent you scored for all of your previous attempts at the quiz.  Clicking 

on a specific node in the graph causes the Selected Attempt section to change to show the specifics of 

that quiz attempt. 



Overall Summary 

 
The Overall Summary shows information based on all your completed attempts for the selected quiz.  

This section displays the following information: 

• Average – This shows the average percent you have scored across all attempts of the quiz. 

• Quiz Attempts – This is a count of how many times in total you have completed the quiz. 

• Highest Score – This shows the highest percentage you have ever scored on the quiz. 

• Highest Score Date – This shows the earliest date that you received your highest score. 

• Lowest Score – This shows the lowest percentage you have ever scored on the quiz. 

• Lowest Score Date – This shows the earliest date that you received your lowest score. 

• Most Recent Score – This shows the percent you received on your most recent attempt at the 

quiz. 

• Most Recent Score Date – This shows the date that you most recently took the quiz on. 

 

Selected Attempt 

 
The Selected Attempt section displays details for the attempt selected in the Quiz Graph.  In the graph 

the selected quiz is indicated by a circled dot.   

This section displays the following information: 

• Attempt – This shows the number of the selected attempt. For example, if you select your third 

attempt this will display a “3”. 

• Date – This shows the date that the attempt was made on. 

• Correct – This is a count of the number of questions you answered correctly in the selected quiz. 

• Incorrect – This is a count of the number of questions you answered incorrectly in the selected 

quiz. 

• Total – This is a count of the total number of questions that were in the quiz.  This count may 

vary from attempt to attempt if the “Ask Questions Until Correct” option was checked in the File 

menu when the quiz was attempted. 

• Score – This is the percentage score for the selected quiz. 

Your performance on a quiz attempt is recorded when you complete 

that attempt.  You are free to start a new quiz or exit SeaLeft FAQ at 

any time; however, if you do so while a quiz attempt is running your 

performance on that attempt will not be recorded and cannot be 

reviewed on the Performance History window. 



 

Creating Quizzes 
Basic Quizzes 
It is possible to create your own quizzes for use within SeaLeft FAQ.  All that is required is a simple text 

editor such as the Notepad application within Windows. This section will show you how to create your 

own quizzes. 

The easiest way to understand how to write a quiz file is to see an example: 

What is the capitol of Canada? 

4 

Ottawa 

Toronto 

Calgary 

Vancouver 

Each question is made up of three sections: 

1. The first line contains the question itself.  In this example, the question is “What is the capitol of 

Canada?”  This is what displays in the Question Area of Sealeft FAQ when the quiz is taken. 

2. The line following the question contains a number that indicates how many possible answers 

the question has.  In this example, the number is “4”, which means that the next four lines are 

the answers that appear in the Answer Area of SeaLeft FAQ when the quiz is taken.  Each 

question may have from two to six answers. 

3. The last section contains one line for each answer that the question has.  In this example, there 

are four possible answers: Ottawa, Toronto, Calgary, and Vancouver.  The correct answer should 

always be placed on the first line of answers, with incorrect answers placed on subsequent lines. 

SeaLeft FAQ will mix up the answers when the question is asked while taking the quiz. 

To create a quiz, simply add as many questions as desired with the format described above.  Note that 

blank lines can be placed at any point in your quiz file as FAQ will ignore them.  This allows you to 

separate out your questions for easier editing in the future. 

Here is an example of a short quiz consisting of three questions: 

What is the capitol of Canada? 

4 

Ottawa 

Toronto 

Calgary 

Vancouver 

 

What province is to the west of Alberta? 

4 

British Columbia 

Saskatchewan 

Ontario 

Quebec 



 

What province contains the capitol of Canada? 

4 

Ontario 

Quebec 

Alberta 

Manitoba 

To try this quiz out, copy the above questions into your text editor. Then save the file as “example.faq”. 

It is important that the file name end with “.faq” as this is the type of file that SeaLeft FAQ looks for. 

Once the file is saved, you can run SeaLeft FAQ as normal.  You can then open the new “example.faq” 

file to see this quiz in action.  For actual quizzes, you can give your file any name that you wish as long as 

it ends with “.faq”.  The name you give to the file is what will display when you take the quiz and will 

also appear in the Quiz List of the Performance History window. 

All of the Above / None of the Above in Quizzes 
When you supply the answers for a quiz question in your “.faq” file there are two special answers that 

are treated differently by SeaLeft FAQ. 

All of the Above 

None of the Above 

If you supply one or both of these as answers, then SeaLeft FAQ will always display them at the end of 

the answer list when running the quiz.  If both are provided as answers, then “None of the Above” will 

always appear below “All of the Above”. 

You can type these two answers in whatever case you like (e.g. “all of the above”, “ALL OF THE ABOVE”, 

“All of the Above”), but the wording must be as shown and no other characters can be part of the 

answer.  For example, do not include a period on the end of the answer.  If the wording is different, then 

the answer will be mixed in with the other answers instead of appearing at the bottom when the 

question is asked in SeaLeft FAQ. 

 


